Lesson 19: Setting Up Sass

I’m going to look into it tomorrow, but I’m getting this output from running npm install gulp-clean-css gulp-sass sass

npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported

> node-sass@4.14.1 install /Users/todd/downtowngrille/node_modules/node-sass
> node scripts/install.js

Downloading binary from https://github.com/sass/node-sass/releases/download/v4.14.1/darwin-x64-79_binding.node
Download complete ░⸩ ⠋ :
Binary saved to /Users/todd/downtowngrille/node_modules/node-sass/vendor/darwin-x64-79/binding.node
Caching binary to /Users/todd/.npm/node-sass/4.14.1/darwin-x64-79_binding.node
node[21048]: ../src/signal_wrap.cc:159:void node::DecreaseSignalHandlerCount(int): Assertion `(new_handler_count) >= (0)' failed.
 1: 0x100081675 node::Abort() [/Users/todd/.nvm/versions/node/v13.2.0/bin/node]
 2: 0x10008141d node::AppendExceptionLine(node::Environment*, v8::Local<v8::Value>, v8::Local<v8::Message>, node::ErrorHandlingMode) [/Users/todd/.nvm/versions/node/v13.2.0/bin/node]
 3: 0x1000f5f0d node::DecreaseSignalHandlerCount(int) [/Users/todd/.nvm/versions/node/v13.2.0/bin/node]
 4: 0x1000f6685 node::(anonymous namespace)::SignalWrap::Close(v8::Local<v8::Value>) [/Users/todd/.nvm/versions/node/v13.2.0/bin/node]
 5: 0x10003a81e node::Environment::CleanupHandles() [/Users/todd/.nvm/versions/node/v13.2.0/bin/node]
 6: 0x10003a9d6 node::Environment::RunCleanup() [/Users/todd/.nvm/versions/node/v13.2.0/bin/node]
 7: 0x1000b3dd0 node::NodeMainInstance::Run() [/Users/todd/.nvm/versions/node/v13.2.0/bin/node]
 8: 0x10005da91 node::Start(int, char**) [/Users/todd/.nvm/versions/node/v13.2.0/bin/node]
 9: 0x7fff73962cc9 start [/usr/lib/system/libdyld.dylib]
[1]    21022 abort      npm install gulp-clean-css gulp-sass sass

I probably shouldn’t have started this one at 11:00 pm but I did… anyone got any ideas? (I’ll read the link to GH tomorrow, it’s enormous). Thanks!

I ended up installing each separately and it works with no issues. Funny how that happened. :man_shrugging:

Yeh that’s a weird one that I haven’t seen yet. Glad you got it sorted and you’re definitely on the fun part of the course now :slightly_smiling_face:

1 Like

It’s been fun from the get go, Andy. Eleventy has become my favorite so I couldn’t pass up the opportunity to get in on this. I know I’ve said it before, but I can’t say it enough the more I dig in… well done!

1 Like

Thank you, that means a lot :slight_smile: